Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 14, 2026 - 09:00 CEST
Scheduled
Following the issues earlier this week, our Engineering team completed a detailed investigation and identified the root cause. A post mortem report will be published later today on our status page.
The impacted components have since been stabilised, and additional checks have been added before proceeding with this release.
We understand the impact this may have had on your operations and sincerely apologise for the inconvenience.
Posted Jun 12, 2026 - 11:09 CEST
This scheduled maintenance affected: Management Portal, Self-service Kiosk, Triggers & Actions, Yard Assistant App, API, and Text messages & E-mail.