Performance issues for a subset of customers

Incident Report for Peripass

Resolved

Wednesday between 12:15 - 12:45, Thursday between 8:45 - 9:30 and 13:10 - 13:50 we experienced elevated exception rate and performance issues.
This issue has been resolved and the service is operating normally.

We apologise for the incident and the inconvenience this might have caused you. We will discuss internally what learnings and mitigating measures we can take to avoid this type of incidents in the future. We will publish a post mortem in the upcoming weeks.

If you have questions or require support, please reach out at https://support.peripass.com/.
Posted Jan 09, 2026 - 15:43 CET

Monitoring

We have found a potential root cause and deployed a fix that should mitigate the problem.
We will keep monitoring closely for the upcoming hours to ensure we have tackled the issue properly.
Posted Jan 08, 2026 - 23:39 CET

Update

The hotfix is being rolled out now.
Posted Jan 08, 2026 - 13:33 CET

Identified

We are preparing a hotfix that should be released at about 1 pm.
Posted Jan 08, 2026 - 11:48 CET

Investigating

We are investigating performance issues.
We will restart our applications to modify a setting.
Posted Jan 08, 2026 - 09:02 CET

Monitoring

The CPU for the database is within acceptable levels and we observe no more customer impact for a while now. We will keep actively monitoring the situation.
Posted Jan 07, 2026 - 15:39 CET

Update

We are still investigating the cause of the issue. We believe high database CPU on one server is the cause and we already took some actions to lower the CPU which seems to provide some relief on the system.
We will provide more details within the next hours.
Posted Jan 07, 2026 - 13:03 CET

Investigating

We're investigating performance issues for a subset of customers.
We will provide more details within the next hours.
Posted Jan 07, 2026 - 10:26 CET
This incident affected: Management Portal, Self-service Kiosk, Triggers & Actions, Yard Assistant App, API, and Text messages & E-mail.