Between 8:28 and 11:10 our SMS service provider Twilio experienced SMS delivery failures to multiple countries via a subset of Twilio long codes. As long codes are only used with Belgian carriers, this incident only affected those recipients. This issue has been resolved, and the service is operating normally.
We apologize for the incident and the inconvenience this might have caused you. We will discuss internally what learnings and mitigating measures we can take to avoid this type of incidents in the future. We will publish a postmortem in the upcoming weeks.
We are continuing to monitor for any further issues.
Posted Dec 04, 2025 - 10:13 CET
Monitoring
Twilio is seeing recovery in SMS delivery delays affecting messages sent via long codes. Alpha Sender IDs were not impacted. Due to legal restrictions, long codes are only used for Belgian numbers, so only those were affected.
We’ll provide another update in 2 hours or sooner if new information becomes available.
Posted Dec 04, 2025 - 10:11 CET
Investigating
Our SMS service provider Twilio is reporting that since approximately 8h30 they are experiencing SMS delivery failures when sending messages to multiple countries. Their engineers are working with their carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.