Peripass degraded performance

Incident Report for Peripass

Postmortem

Summary

On Tuesday 9 June 2026 between 09:02 and 10:05 CEST, we experienced degraded performance.

The issue occurred during volume ramp-up after the 1.66 release and the follow-up patch. To minimize customer impact, we performed a rollback on Tuesday morning.

Impact

During this window, users may have experienced degraded performance when using Peripass.

Root Cause

The issue was caused by two release-related performance problems.

  • Feature flags were checked synchronously on a hot path. This introduced significant performance impact under production load.
  • Dispatch Dashboard refreshes increased unexpectedly. This was caused by an incomplete cleanup after feature flag removal and related infrastructure changes. The increased refresh traffic caused additional load and application restarts, which contributed to the degraded performance.

These issues were not detected during staging validation because the production traffic pattern and feature-flag behavior were not sufficiently reproduced.

Follow-up

We removed a component that allowed the use of feature flags in middleware and other hot paths. We also added automatic code analysis to restrict the use of the same pattern in the future.

We’ve hardened our feature flag removal process. The current fix has been validated and stress tested to confirm the performance issue is resolved.

Posted Jun 12, 2026 - 13:56 CEST

Resolved

Between 09:02 and 10:05 we experienced degraded performance.
This issue has been resolved and the service is operating normally.

We apologise for the incident and the inconvenience this might have caused you. We will discuss internally what learnings and mitigating measures we can take to avoid this type of incidents in the future. We will publish a post mortem in the upcoming weeks.

If you have questions or require support, please reach out at https://support.peripass.com/.
Posted Jun 09, 2026 - 14:42 CEST

Monitoring

We have taken measures that should mitigate the problem.
We will keep monitoring closely for the upcoming hours to ensure we have tackled the issue properly.
Posted Jun 09, 2026 - 10:04 CEST

Investigating

We are investigating degraded performance that started at 09:00.
We will provide more details within the next hours.
Posted Jun 09, 2026 - 09:25 CEST
This incident affected: Management Portal and Self-service Kiosk.