Management Portal Slow Response for a subset of customers

Incident Report for Peripass

Postmortem

Summary

Peripass experience failed requests on 2025-01-08 between 08:48-09:43 and 10:30-10:50 on 2 components. A restart of the unhealthy instance was required to stabilize the platform.

Impact

Some customers experienced failed requests during the incident, necessitating multiple retries to successfully complete their actions.

Root cause

The unhealthy instance was unable to recover automatically due to resource starvation during peak loads. The platform experienced similar behavior during the incidents on 2025-01-27, 2025-12-10 & 2024-12-04.

Action plan & next steps

We’ve further scaled up our infrastructure to be able to handle the increased load on our platform. We’ll continue to monitor the consumption and take additional actions if necessary.

Posted Feb 24, 2025 - 11:58 CET

Resolved

Between 08:48-09:43 and 10:30-10:50 we experienced slow responses for a subset of customers.
This issue has been resolved and the service is operating normally.

We apologise for the incident and the inconvenience this might have caused you. We will discuss internally what learnings and mitigating measures we can take to avoid this type of incidents in the future. We will publish a post mortem in the upcoming weeks.

If you have questions or require support, please reach out at https://support.peripass.com/.
Posted Jan 08, 2025 - 12:16 CET

Monitoring

We will keep monitoring closely for the upcoming hours to ensure we have tackled the issue properly.
Posted Jan 08, 2025 - 11:01 CET

Identified

We are still investigating this issue and will provide more details within the next hours.
Posted Jan 08, 2025 - 10:39 CET

Monitoring

We will keep monitoring closely for the upcoming hours to ensure we have tackled the issue properly.
Posted Jan 08, 2025 - 10:03 CET

Investigating

We are investigating performance issues on the management portal and the self service Kiosk.
We will provide more details within the next hours.
Posted Jan 08, 2025 - 09:02 CET
This incident affected: Management Portal and Self-service Kiosk.