Between 14:54 and 16:03 we experienced Delays in trigger execution are causing actions to be missed or dropped. This issue has been resolved and the service is operating normally.
We apologise for the incident and the inconvenience this might have caused you. We will discuss internally what learnings and mitigating measures we can take to avoid this type of incidents in the future. We will publish a post mortem in the upcoming weeks.
We have found the root cause and deployed a fix that should mitigate the problem. We will keep monitoring closely for the upcoming hours to ensure we have tackled the issue properly.
Posted Sep 10, 2025 - 16:05 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 10, 2025 - 15:40 CEST
Update
The delays are due to overflowing queues, with wait times now exceeding five minutes and causing actions to be dropped. We've identified the root cause of the overflow and are currently working on a fix. Once resolved, we’ll clean up the queues. Until then, no actions will be executed. We’ll update the incident as soon as the fix is complete.
Posted Sep 10, 2025 - 15:39 CEST
Update
We are continuing to investigate this issue.
Posted Sep 10, 2025 - 15:29 CEST
Investigating
We are investigating an issue where we notice delays on triggers and actions.
We will provide more details within the next hours.